Installation

Prerequisites

Exscript requires Python 2.7, and the following modules:

future
configparser
pycrypto
paramiko

Installing with PIP

sudo pip install exscript

Installing from GitHub

git clone git://github.com/knipknap/exscript
cd exscript
sudo make install

Running the automated test suite

If you installed from GitHub, you can run the integrated testsuite:

make tests

There shouldn’t be any errors, so if something comes up, please file a bug.